(© 1997-2008 by Francisco Panizo Beceiro)

Se você quer uma Ajuda Específica para o seu caso, proceda como indicado:
clique Suporte, e envie a sua dúvida (para cadastrados no CLUBE DO HELP DESK)
ou envie sua dúvida para nosso Super Fórum )

Todas emoções da categoria monoposto dos EUA

Seção EXCEL da abcDICAS.com.br

Formatação Condicional no Excel 97

É muito comum termos de colocar como resultado final de um cálculo, não o valor puro, mas sim uma resposta, composta por uma palavra ou sentença, condicionada ao resultado numérico obtido. A isso chamamos de Respostas Condicionais.

Um bom exemplo é o do controle de aprovação de uma classe de alunos. Se um aluno tirar média final maior a 6 ele estará APROVADO, em caso da média ficar entre 4 e 6 deverá ir para EXAME, enquanto que se tiver média inferior a 4 estará REPROVADO.

Vamos a planilha que nos servirá como exemplo, adapte-a para atender às suas necessidades:

  A B C D E
1 NOME NOTA1 NOTA2 MÉDIA RESULTADO
2 Francisco 7 9 8,0 APROVADO
3 José 3 8 5,5 EXAME
4 Maria 7 4 5,5 EXAME
5 Carla 5 7 6,0 EXAME
6 Mota 4 3 3,5 REPROVADO

A nossa necessidade: colocar as expressões "Aprovado", "Exame" ou "Reprovado" na coluna E, de acordo com a média final do aluno (que se encontra na coluna D). Como fazer? Simples, siga os passos abaixo:

  1. Coloque o cursor na célula E2 e digite a fórmula:
    =SE(D2>6; "APROVADO"; SE(D2<4; "REPROVADO"; "EXAME" ))
    ;
  2. Copie a fórmula por todas as demais células da coluna E, no exemplo até a linha 6;

Pronto, já podemos saber e/ou mostrar quem passou, quem não passou, ou mesmo quem vai ter fazer o EXAME FINAL, sem precisar prestar, muita, atenção aos números da coluna D.


Bem, terminou! Não? ah, já sei, tem sempre alguém querendo ainda mais, para dar maior e melhor visibilidade aos resultados, mesmo que já estejam mais claros. O que seria agora? Por que não colocar as respostas diferenciadas em azul (para os aprovados), verde (para quem vai para os exames) e vermelho (para os não aprovados). Como fazer?.

A melhor solução é usar o recurso da FORMATAÇÃO CONDICIONAL exclusiva do Excel 97. Veja como montar essa planilha:

  1. Entre na planilha e selecione toda a faixa de células que devam ser formatadas condicionalmente;
  2. Selecione o menu Formatar * Formatação Condicional;
  3. Ao se abrir a janela "Formatação Condicional" (fig. 1) altere a condição 1 para IGUAL A
    e preencha o campo de resultado com a expressão ="REPROVADO";
  4. Nessa mesma janela clique no botão FORMATAR;
  5. Ao se abrir a janela "Formatar Células" (fig. 1) selecione as opções desejadas
    no caso, pelo menos escolha a cor VERMELHA;
  6. Pressione o botão "ADICIONAR>>";
  7. Ao se abrir mais um grupo de formatação condicional repita os passos #3 à #5
    só que desta vez defina expressão ="EXAME" e a cor VERDE;
  8. Pressione o botão "ADICIONAR>>";
  9. Ao se abrir mais um grupo de formatação condicional repita os passos #3 à #5
    só que desta vez defina expressão ="APROVADO" e a cor AZUL;

Pronto, o resultado final deverá ficar parecido com a tabela abaixo:

  A B C D E
1 NOME NOTA1 NOTA2 MÉDIA RESULTADO
2 Francisco 7 9 8,0 APROVADO
3 José 3 8 5,5 EXAME
4 Maria 7 4 5,5 EXAME
5 Carla 5 7 6,0 EXAME
6 Mota 4 3 3,5 REPROVADO

 


Figura 1: Montagem da Formatação Condicional; perceba que só se pode alterar o Estilo da Fonte, Sublinhado, Tachado, e a Cor da Fonte;

PS: O Excel 97 entretanto só permite até 3 condições simultaneamente; a figura #2 mostra a janela de Formatação Condicional que usa todas as 3 condições simultaneamente:


Figura 2: A tela de formatação condicional mostrando 3 opções condicionais diferentes - o máximo possível no Excel 97;


Uma aplicação mais complexa, mas também bem prática, podemos simplificar, para efeitos didáticos como abaixo:

Quero fazer com que seja fornecida uma situação de pagamento em que se uma data do vencimento for menor que a data de hoje (=hoje()) então escreva "Pagamento OK", se for igual "Pagamento Hoje" senão "Pagamento
em: dia/mês/ano", e se a data estiver em branco escreva "Digite a DATA"; para isso usei a seguinte fórmula, onde: B10, B11... ficam as datas de vencimento e E3 =hoje():
=SE(B10="";"Digite a data";SE(B10<$E$3;"Pagto OK";SE(B10=($E$3);"Pagto Hoje";"Pagto em: " &DIA(B10) &"/"
&MÊS(B10) &"/" &ANO(B10))))
Mas quero que as respostas apareçam em cores diferentes, existe alguma forma de se fazer isso?

O problema aqui é que há necessidade de 4 condições diferentes:

  1. campo data está em branco;
  2. data preenchida com valor anterior à data de hoje;
  3. data preenchida com valor idêntico à data de hoje;
  4. data preenchida com valor superior à data de hoje;

E como colocamos, mais acima, o Excel 97 só permite a existência de até 3 condições. Como fazer?

Simples, basta usarmos as 3 condições que o Excel permite, e a outra condição deixar como a condição normal de formatação das células:

Vencimento Comentários
12/12/98 PAGTO. OK
24/12/98 PAGTO. OK
28/12/98 Pagto em: 28/12/1998
25/12/98 PAGTO. HOJE
DIGITE A DATA
Neste exemplo considera-se que a data de hoje é 25/12/98

Como o Excel 97 não permite condições mais complexas na janela de Formatação Condicional deixamos então a opção de concatenação de elementos de data fora da janela.

Neste exemplo prático, utilizamos a fórmula do Daniel, copiando-a pela região dos comentários. À seguir fizemos a Formatação Condicional, como indicado na figura #3; para todas as células da região entretanto fizemos uma formatação normal, usando fonte em itálico e cor verde; assim quando não for verdadeira nenhuma das opções da formatação condicional o Excel já formatará as entradas correspondentes do jeito necessário para a quarta condição.


Figura 3: A tela de formatação condicional mostrando o exemplo prático mostrado neste página;

 

Se você quiser a planilha de exemplo desta página (EXCEL 97) CLIQUE AQUI...
| Home |

Todo o material deste Portal tem copyright by Francisco Panizo,
assim sendo fica proibida sua cópia e reprodução não autorizadas.